const regex = /<img.+?src=["'](.+?)["'].*?>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<img.+?src=["\'](.+?)["\'].*?>', 'gm')
const str = `// it shouldn't match custom tag 'imgs-tag'
<imgs-tag class="hero-class" src="image.jpg">
// it shouldn't match custom attribute 'data-src'
<img data-src="custom info" src="image.jpg">
// it should match whole src attribute, not just part
<img class="hero-class" src="mcdonald's.jpg">
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}