$re = '/<img.+?src=["\'](.+?)["\'].*?>/m';
$str = '// it shouldn\'t match custom tag \'imgs-tag\'
<imgs-tag class="hero-class" src="image.jpg">
// it shouldn\'t match custom attribute \'data-src\'
<img data-src="custom info" src="image.jpg">
// it should match whole src attribute, not just part
<img class="hero-class" src="mcdonald\'s.jpg">
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);