using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.?[Uu]buntu)";
string input = @"Ubuntu
Kubuntu
Xubuntu
Fubuntu
Mubuntu
Hubuntu
Yubuntu
Webuntu
OH NO!";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}