package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.?[Uu]buntu)`)
var str = `Ubuntu
Kubuntu
Xubuntu
Fubuntu
Mubuntu
Hubuntu
Yubuntu
Webuntu
OH NO!`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}