$re = '/(.?[Uu]buntu)/m';
$str = 'Ubuntu
Kubuntu
Xubuntu
Fubuntu
Mubuntu
Hubuntu
Yubuntu
Webuntu
OH NO!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);