re = /(.?[Uu]buntu)/m
str = 'Ubuntu
Kubuntu
Xubuntu
Fubuntu
Mubuntu
Hubuntu
Yubuntu
Webuntu
OH NO!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end