#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(-?\d\.\d{14})\s(-?\d\.\d{14})\s(-?\d\.\d{14})\s([oh])"
Local $sString = "-0.12345678901234 -0.12345678901234 0.00000000000000 o" & @CRLF & _
"-0.12345678901234 -0.12345678901234 0.00000000000000 h"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")