$re = '/(-?\d\.\d{14})\s(-?\d\.\d{14})\s(-?\d\.\d{14})\s([oh])/m';
$str = '-0.12345678901234 -0.12345678901234 0.00000000000000 o
-0.12345678901234 -0.12345678901234 0.00000000000000 h';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);