import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(-?\\d\\.\\d{14})\\s(-?\\d\\.\\d{14})\\s(-?\\d\\.\\d{14})\\s([oh])";
final String string = "-0.12345678901234 -0.12345678901234 0.00000000000000 o\n"
+ "-0.12345678901234 -0.12345678901234 0.00000000000000 h";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}