// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(-?\d\.\d{14})\s(-?\d\.\d{14})\s(-?\d\.\d{14})\s([oh])").unwrap();
let string = "-0.12345678901234 -0.12345678901234 0.00000000000000 o
-0.12345678901234 -0.12345678901234 0.00000000000000 h";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}