const regex = /[+]?(?<!\d)(?<!\d[ -])
(?:
((\d{1,2}[ -]?)?[(]?\d{3}[)]?[ -]?)
(\d(?:[ -]?\d){3,6})
)(?![ -]?\d)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[+]?(?<!\\d)(?<!\\d[ -])
(?:
((\\d{1,2}[ -]?)?[(]?\\d{3}[)]?[ -]?)
(\\d(?:[ -]?\\d){3,6})
)(?![ -]?\\d)', 'g')
const str = `Matches:
--------
1234567 123 45 67 123-45-67
123456789012 12 345 678 9012 12-345-678-90-12
1 234 56 78 912 1 234 56 789 12 1 234 567 8 901
+1234567
+1234567890 +12-234 561 78 90 +12 234-561-78-90
+123456789012
+1 234 561 78 90
1(234)567-89-01
(495)1234567 (495) 123 45 67
+33 (014)-020 53 17
Doesn't match:
--------------
+123456 -- to short
+1234567890123 -- too long
123 4567890123 -- too long`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}