$re = '/[+]?(?<!\d)(?<!\d[ -])
(?:
((\d{1,2}[ -]?)?[(]?\d{3}[)]?[ -]?)
(\d(?:[ -]?\d){3,6})
)(?![ -]?\d)/x';
$str = 'Matches:
--------
1234567 123 45 67 123-45-67
123456789012 12 345 678 9012 12-345-678-90-12
1 234 56 78 912 1 234 56 789 12 1 234 567 8 901
+1234567
+1234567890 +12-234 561 78 90 +12 234-561-78-90
+123456789012
+1 234 561 78 90
1(234)567-89-01
(495)1234567 (495) 123 45 67
+33 (014)-020 53 17
Doesn\'t match:
--------------
+123456 -- to short
+1234567890123 -- too long
123 4567890123 -- too long';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);