#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?!n\\a$)(?!none$)(.*[A-Za-z].*)"
Local $sString = "foo" & @CRLF & _
"none" & @CRLF & _
"none1" & @CRLF & _
"n\a" & @CRLF & _
"n\aa" & @CRLF & _
"1234" & @CRLF & _
"NONE" & @CRLF & _
"N\A" & @CRLF & _
"NONEX"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")