import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!n\\\\a$)(?!none$)(.*[A-Za-z].*)";
final String string = "foo\n"
+ "none\n"
+ "none1\n"
+ "n\\a\n"
+ "n\\aa\n"
+ "1234\n"
+ "NONE\n"
+ "N\\A\n"
+ "NONEX";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}