re = /^(?!n\\a$)(?!none$)(.*[A-Za-z].*)/mi
str = 'foo
none
none1
n\\a
n\\aa
1234
NONE
N\\A
NONEX'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end