$re = '/^(?!n\\\\a$)(?!none$)(.*[A-Za-z].*)/mi';
$str = 'foo
none
none1
n\\a
n\\aa
1234
NONE
N\\A
NONEX';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);