use strict;
my $str = 'I. Allegro (in B-flat major and in sonata form)
II. Tema con variazioni (Andante) (theme and 6 variations, where the theme and all the variations are in F major)
III. Menuetto - Trio (in B-flat major and in ternary form, trio in G minor)
IV. Adagio (in E-flat major and in sonata form)
V. Menuetto - Trio (in B-flat major and in ternary form, trio in E-flat major)
VI. Andante - Allegro molto (in B-flat major, beginning with an introductory instrumental recitative, and in sonata rondo form)';
my $regex = qr/\(.*?\)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}