// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\(.*?\)").unwrap();
let string = "I. Allegro (in B-flat major and in sonata form)
II. Tema con variazioni (Andante) (theme and 6 variations, where the theme and all the variations are in F major)
III. Menuetto - Trio (in B-flat major and in ternary form, trio in G minor)
IV. Adagio (in E-flat major and in sonata form)
V. Menuetto - Trio (in B-flat major and in ternary form, trio in E-flat major)
VI. Andante - Allegro molto (in B-flat major, beginning with an introductory instrumental recitative, and in sonata rondo form)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}