$re = '/\(.*?\)/m';
$str = 'I. Allegro (in B-flat major and in sonata form)
II. Tema con variazioni (Andante) (theme and 6 variations, where the theme and all the variations are in F major)
III. Menuetto - Trio (in B-flat major and in ternary form, trio in G minor)
IV. Adagio (in E-flat major and in sonata form)
V. Menuetto - Trio (in B-flat major and in ternary form, trio in E-flat major)
VI. Andante - Allegro molto (in B-flat major, beginning with an introductory instrumental recitative, and in sonata rondo form)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);