import re
regex = re.compile(r"\(.*?\)", flags=re.MULTILINE)
test_str = ("I. Allegro (in B-flat major and in sonata form)\n"
"II. Tema con variazioni (Andante) (theme and 6 variations, where the theme and all the variations are in F major)\n"
"III. Menuetto - Trio (in B-flat major and in ternary form, trio in G minor)\n"
"IV. Adagio (in E-flat major and in sonata form)\n"
"V. Menuetto - Trio (in B-flat major and in ternary form, trio in E-flat major)\n"
"VI. Andante - Allegro molto (in B-flat major, beginning with an introductory instrumental recitative, and in sonata rondo form)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")