package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?x)Required\sDate
__
(?<PartNo1>[a-zA-Z0-9-]*\s
[0-9.]+)
__
(?<PartNo2>[a-zA-Z0-9-]*\s
[0-9.]+)`)
var str = `__Required Date__40X0343 1.00__C734X77G 2.00__Net Order:__Sales Tax:__Freight:__Order Total:__0.00 __0.00 __5,328.50 __5,328.50 __or by fax
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}