// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?x)Required\sDate
__
(?<PartNo1>[a-zA-Z0-9-]*\s
[0-9.]+)
__
(?<PartNo2>[a-zA-Z0-9-]*\s
[0-9.]+)").unwrap();
let string = "__Required Date__40X0343 1.00__C734X77G 2.00__Net Order:__Sales Tax:__Freight:__Order Total:__0.00 __0.00 __5,328.50 __5,328.50 __or by fax
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}