const regex = /(?x)Required\sDate
__
(?<PartNo1>[a-zA-Z0-9-]*\s
[0-9.]+)
__
(?<PartNo2>[a-zA-Z0-9-]*\s
[0-9.]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?x)Required\\sDate
__
(?<PartNo1>[a-zA-Z0-9-]*\\s
[0-9.]+)
__
(?<PartNo2>[a-zA-Z0-9-]*\\s
[0-9.]+)', 'gm')
const str = `__Required Date__40X0343 1.00__C734X77G 2.00__Net Order:__Sales Tax:__Freight:__Order Total:__0.00 __0.00 __5,328.50 __5,328.50 __or by fax
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}