import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?x)Required\\sDate\n"
+ "__\n"
+ "(?<PartNo1>[a-zA-Z0-9-]*\\s\n"
+ "[0-9.]+)\n"
+ "__\n"
+ "(?<PartNo2>[a-zA-Z0-9-]*\\s\n"
+ "[0-9.]+)";
final String string = "__Required Date__40X0343 1.00__C734X77G 2.00__Net Order:__Sales Tax:__Freight:__Order Total:__0.00 __0.00 __5,328.50 __5,328.50 __or by fax \n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}