#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "defmodule ([a-zA-Z]+) do\n([\s\S]*)end"
Local $sString = "defmodule Test do" & @CRLF & _
" def dupa(a, b) do" & @CRLF & _
" a + b" & @CRLF & _
" end" & @CRLF & _
"end"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")