import re
regex = re.compile(r"defmodule ([a-zA-Z]+) do\n([\s\S]*)end")
test_str = ("defmodule Test do\n"
" def dupa(a, b) do\n"
" a + b\n"
" end\n"
"end")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")