#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ".. figure:: (.*?)(\n{2}[ ]{3}.*\n)"
Local $sString = "An example of the **Horizon Mapping** dialog box is shown below. A " & @CRLF & _
"summary of the main features is given below. " & @CRLF & _
"" & @CRLF & _
".. figure:: horizon_mapping_dialog_horizons_tab.png" & @CRLF & _
"" & @CRLF & _
" **Horizon Mapping** dialog box, *Horizons*" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"Some of the input values to the **Horizon Mapping** job can be changed " & @CRLF & _
"during a Workflow using the internal programming language, IPL. For " & @CRLF & _
"details, refer to the *IPL User Guide*. " & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")