import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".. figure:: (.*?)(\\n{2}[ ]{3}.*\\n)";
final String string = "An example of the **Horizon Mapping** dialog box is shown below. A \n"
+ "summary of the main features is given below. \n\n"
+ ".. figure:: horizon_mapping_dialog_horizons_tab.png\n\n"
+ " **Horizon Mapping** dialog box, *Horizons*\n\n"
+ " \n"
+ "Some of the input values to the **Horizon Mapping** job can be changed \n"
+ "during a Workflow using the internal programming language, IPL. For \n"
+ "details, refer to the *IPL User Guide*. \n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}