re = /.. figure:: (.*?)(\n{2}[ ]{3}.*\n)/
str = 'An example of the **Horizon Mapping** dialog box is shown below. A
summary of the main features is given below.
.. figure:: horizon_mapping_dialog_horizons_tab.png
**Horizon Mapping** dialog box, *Horizons*
Some of the input values to the **Horizon Mapping** job can be changed
during a Workflow using the internal programming language, IPL. For
details, refer to the *IPL User Guide*.
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end