# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".. figure:: (.*?)(\n{2}[ ]{3}.*\n)"
test_str = ("An example of the **Horizon Mapping** dialog box is shown below. A \n"
"summary of the main features is given below. \n\n"
".. figure:: horizon_mapping_dialog_horizons_tab.png\n\n"
" **Horizon Mapping** dialog box, *Horizons*\n\n"
" \n"
"Some of the input values to the **Horizon Mapping** job can be changed \n"
"during a Workflow using the internal programming language, IPL. For \n"
"details, refer to the *IPL User Guide*. \n")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.