using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:(?:(?:TRUE?)*?(FR)(?:ENCH)*?)|(?:(EN)(?:GLISH)*?)|(?:(SPA)(?:NISH)*?)|(?:(VF)i?))\b";
string input = @"passenger.57.1992.en.multi.truefrench.1080p.BR.rip.VF-LD-Pal.v-ger06.www.zone-telechargement-spanish.com.mkv";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}