$re = '/\b(?:(?:(?:TRUE?)*?(FR)(?:ENCH)*?)|(?:(EN)(?:GLISH)*?)|(?:(SPA)(?:NISH)*?)|(?:(VF)i?))\b/i';
$str = 'passenger.57.1992.en.multi.truefrench.1080p.BR.rip.VF-LD-Pal.v-ger06.www.zone-telechargement-spanish.com.mkv';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);