import re
regex = re.compile(r"\b(?:(?:(?:TRUE?)*?(FR)(?:ENCH)*?)|(?:(EN)(?:GLISH)*?)|(?:(SPA)(?:NISH)*?)|(?:(VF)i?))\b", flags=re.IGNORECASE)
test_str = "passenger.57.1992.en.multi.truefrench.1080p.BR.rip.VF-LD-Pal.v-ger06.www.zone-telechargement-spanish.com.mkv"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")