re = /\b(?:(?:(?:TRUE?)*?(FR)(?:ENCH)*?)|(?:(EN)(?:GLISH)*?)|(?:(SPA)(?:NISH)*?)|(?:(VF)i?))\b/i
str = 'passenger.57.1992.en.multi.truefrench.1080p.BR.rip.VF-LD-Pal.v-ger06.www.zone-telechargement-spanish.com.mkv'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end