# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<prefix>{[^\\}]++)(?<first_lvl_command>\\\w+(?:\[[^]]++]?({(?:[^{}]+|(?3))*+}))({(?:[^{}]+|(?3))*+})?)(?<closing_bracket>})/$prefix {$first_lvl_command$closing_bracket}/gm;t' <<< "\rpl{text}{ some\com1[opts]{ some \qtyrange{100}{200}{\celsius} and }{something else \gls{abc} $1=1$ not \colortext{\red}{\underline{text}}}} but this is already braced {\qtyrange{100}{200}{\celsius}}}
"