// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?<prefix>{[^\\}]++)(?<first_lvl_command>\\\w+(?:\[[^]]++]?({(?:[^{}]+|(?3))*+}))({(?:[^{}]+|(?3))*+})?)(?<closing_bracket>})").unwrap();
let string = "\\rpl{text}{ some\\com1[opts]{ some \\qtyrange{100}{200}{\\celsius} and }{something else \\gls{abc} $1=1$ not \\colortext{\\red}{\\underline{text}}}} but this is already braced {\\qtyrange{100}{200}{\\celsius}}}
";
let substitution = "$prefix {$first_lvl_command$closing_bracket}";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}