$re = '/(?<prefix>{[^\\\\}]++)(?<first_lvl_command>\\\\\w+(?:\[[^]]++]?({(?:[^{}]+|(?3))*+}))({(?:[^{}]+|(?3))*+})?)(?<closing_bracket>})/m';
$str = '\\rpl{text}{ some\\com1[opts]{ some \\qtyrange{100}{200}{\\celsius} and }{something else \\gls{abc} $1=1$ not \\colortext{\\red}{\\underline{text}}}} but this is already braced {\\qtyrange{100}{200}{\\celsius}}}
';
$subst = "$prefix {$first_lvl_command$closing_bracket}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;