# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<===)\s*'(\S+?)'/("$1")/gm;t' <<< "flag1 == 'hello' and flag2=='hello2'"