import Foundation
let pattern = #"(?<===)\s*'(\S+?)'"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"flag1 == 'hello' and flag2=='hello2'"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"("$1")"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)