re = /(?<===)\s*'(\S+?)'/m
str = 'flag1 == \'hello\' and flag2==\'hello2\''
subst = '("$1")'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result