#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\s*==\s*'(\S+?)'"
Local $sString = "flag1 == 'hello' and flag2=='hello2'"
Local $sSubst = "("$1")"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)