using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*==\s*'(\S+?)'";
string substitution = @"(""$1"")";
string input = @"flag1 == 'hello' and flag2=='hello2'";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}