use strict;
my $str = 'flag1 == \'hello\' and flag2==\'hello2\'';
my $regex = qr/\s*==\s*'(\S+?)'/mp;
my $subst = '("$1")';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";