package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s*==\s*'(\S+?)'`)
var str = `flag1 == 'hello' and flag2=='hello2'`
var substitution = "("$1")"
fmt.Println(re.ReplaceAllString(str, substitution))
}