import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(([^@]|[a-zA-Z\\d.+ -]*)(?=@)@([a-zA-Z\\d-]*)\\.[a-zA-Z]+)$";
final String string = "Valid email addresses\n\n"
+ "123@321.tld\n\n"
+ "prettyandsimple@example.com\n"
+ "very.common@example.com\n"
+ "disposable.style.email.with+symbol@example.com\n"
+ "other.email-with-dash@example.com\n"
+ "x@example.com\n"
+ "\"much.more unusual\"@example.com\n"
+ "\"very.unusual.@.unusual.com\"@example.com\n"
+ "\"very.(),:;<>[]\\\".VERY.\\\"very@\\\\ \\\"very\\\".unusual\"@strange.example.com\n"
+ "example-indeed@strange-example.com\n"
+ "admin@mailserver1\n"
+ "#!$%&'*+-/=?^_`{}|~@example.org\n"
+ "\"()<>[]:,;@\\\\\\\"!#$%&'-/=?^_`{}| ~.a\"@example.org\n"
+ "\" \"@example.org\n"
+ "example@localhost\n"
+ "example@s.solutions\n"
+ "user@localserver\n"
+ "user@tt\n"
+ "user@[IPv6:2001:DB8::1]\n\n\n"
+ "Invalid email addresses[edit]\n"
+ "saas@saas\n"
+ "123@321.345\n"
+ "Abc.example.com\n"
+ "A@b@c@example.com\n"
+ "a\"b(c)d,e:f;g<h>i[j\\k]l@example.com\n"
+ "just\"not\"right@example.com\n"
+ "this is\"not\\allowed@example.com\n"
+ "this\\ still\\\"not\\\\allowed@example.com\n"
+ "john..doe@example.com\n"
+ "with caveat: Gmail lets this through, Email address#Local-part the dots altogether\n"
+ "john.doe@example..com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}