$re = '/^(([^@]|[a-zA-Z\d.+ -]*)(?=@)@([a-zA-Z\d-]*)\.[a-zA-Z]+)$/m';
$str = 'Valid email addresses
123@321.tld
prettyandsimple@example.com
very.common@example.com
disposable.style.email.with+symbol@example.com
other.email-with-dash@example.com
x@example.com
"much.more unusual"@example.com
"very.unusual.@.unusual.com"@example.com
"very.(),:;<>[]\\".VERY.\\"very@\\\\ \\"very\\".unusual"@strange.example.com
example-indeed@strange-example.com
admin@mailserver1
#!$%&\'*+-/=?^_`{}|~@example.org
"()<>[]:,;@\\\\\\"!#$%&\'-/=?^_`{}| ~.a"@example.org
" "@example.org
example@localhost
example@s.solutions
user@localserver
user@tt
user@[IPv6:2001:DB8::1]
Invalid email addresses[edit]
saas@saas
123@321.345
Abc.example.com
A@b@c@example.com
a"b(c)d,e:f;g<h>i[j\\k]l@example.com
just"not"right@example.com
this is"not\\allowed@example.com
this\\ still\\"not\\\\allowed@example.com
john..doe@example.com
with caveat: Gmail lets this through, Email address#Local-part the dots altogether
john.doe@example..com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);