import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=^.{4}).*$";
final String string = "1953-1-1;-0.2\n"
+ "1953-1-2;-0.2\n"
+ "1953-1-3;-0.2\n"
+ "1953-1-4;-0.1";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}