const regex = /(?<=^.{4}).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=^.{4}).*$', 'gm')
const str = `1953-1-1;-0.2
1953-1-2;-0.2
1953-1-3;-0.2
1953-1-4;-0.1`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);