$re = '/(?<=^.{4}).*$/m';
$str = '1953-1-1;-0.2
1953-1-2;-0.2
1953-1-3;-0.2
1953-1-4;-0.1';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;