#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[0-9A-F]{1,2})(?:,[0-9A-F]{1,2})*$"
Local $sString = "1,2,3,4" & @CRLF & _
"A,B,C,D" & @CRLF & _
"10,11,12,13" & @CRLF & _
"10,AA,BB,CC" & @CRLF & _
"1,x" & @CRLF & _
"1" & @CRLF & _
"FF" & @CRLF & _
"FF,1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")